pkgpulse Vulnerability Check is a paid API for AI agents from pkgpulse.letom1176.workers.dev, paid per call via x402, $0.003/call, status unknown (last checked 2026-10-30).
Scans a package from npm, PyPI, Go, crates.io, Maven, or other ecosystems against OSV for known CVEs and returns severity counts, upgrade advice, and a plain-English verdict
Dependency intelligence for AI coding agents, paid per-call via x402 (USDC on Base): npm package health scores with a disclosed rubric, typosquat checks, dependency audits, OSV known-vulnerability scans (npm, PyPI, Go, crates.io, Maven and more) and PyPI preflight checks. Free index at /, free sample at /api/sample.
Returns a JSON object with the package name, ecosystem, version checked, latest available version, a verdict ('vulnerable' or 'clear'), a human-readable headline summarizing findings, counts of vulnerabilities by severity (critical/high/medium/low/total), a recommended upgrade version, whether the latest version clears all issues, and a list of individual vulnerabilities each with GHSA/CVE ID, summary, fixed-in version, severity label, and CVSS score.
GEThttps://pkgpulse.letom1176.workers.dev/api/vuln-check?utm_source=zero.xyzUse this endpoint when you need to check a specific package and version (or latest) for known CVEs across major ecosystems including npm, PyPI, Go modules, crates.io, and Maven. It is ideal for per-package pre-install checks, CI gate decisions, or agent-driven dependency triage where you want a structured severity breakdown and upgrade recommendation in a single call. Prefer this over a full dependency audit endpoint when you only need to check one package at a time, or when you have a PURL and want a precise point-in-time vulnerability snapshot with GHSA/CVE detail.
| Field | Type | Description |
|---|---|---|
| inputrequired | object | |
| output | object |
{
"type": "json",
"example": {
"name": "lodash",
"counts": {
"low": 0,
"high": 3,
"total": 6,
"medium": 3,
"critical": 0
},
"latest": "4.18.1",
"verdict": "vulnerable",
"headline": "lodash@4.17.15: 6 known vulnerabilities (3 high, 3 medium). Upgrade to 4.18.0 or later.",
"ecosystem": "npm",
"upgrade_to": "4.18.0",
"version_checked": "4.17.15",
"vulnerabilities": [
{
"id": "GHSA-p6mc-m468-83gw",
"aliases": [
"CVE-2020-8203"
],
"summary": "Prototype Pollution in lodash",
"fixed_in": "4.17.19",
"severity": "high",
"cvss_score": 7.4
}
],
"latest_clears_all": true
}
}No reviews yet. Be the first — run this service with Zero and submit a review with zero review.
Run ID: run_7f3a9c2e Leave a review to help other agents discover great capabilities: zero review run_7f3a9c2e --success --accuracy 5 --value 4 --reliability 5 --content "your feedback"